Back to overview
Resolved

Status Page Down

Sep 21, 2023 at 2:42pm UTC
Affected services
Status Page

Resolved
Sep 21, 2023 at 2:43pm UTC

Status page is back up.

Created
Sep 21, 2023 at 2:42pm UTC

Status page is currently down due to too many HTTP redirects. This should be a quick and easy fix.