Back to overview
Degraded

Non-secure connection on some browsers

Oct 24 at 12:18am EDT
Affected services
StormWatch Website

Resolved
Oct 24 at 12:45am EDT

fixed

Updated
Oct 24 at 12:26am EDT

intermittently, we have begun showing a captcha before website entry to ensure no bad traffic enters the website.

Currently just an opera issue, the following browsers reported secure connection:
* Safari
* Google Chrome
* Microsoft edge
* Firefox

Will continue investigating the issue.

Created
Oct 24 at 12:18am EDT

Currently investigating an issue where some browsers are showing our site is not secure despite having a valid SSL.

Known browsers:
Opera
OperaGX